Compatibilidad ASP.NET 1.1 y ASP.NET 2.0

Recientemente Microsoft ha sacado la versión 2.0 de ASP.net.

 

La pregunta más frecuente es: ¿qué tipo de compatibilidad con mis programas ASP 1.1 soportará?

 

Resumiendo: podemos decir que la compatibilidad es a nivel de archivos compilados (assemblies) y no de código fuente.

 

Es decir, podemos conservar nuestros aplicativos existentes e incluso comunicarnos con los nuevos mediante referencias, pero NO podremos compilar nuestro proyecto ASP1.1 contra un compilador de 2.0 al menos con las versiones actuales de VS2005.

 

Por defecto al instalar la versión 2.0 de .net framework el sistema actualizará todos los aplicativos web para que se ejecuten contra la versión 2.0 esto no debería dar demasiados problemas con  una  excepción: los ficheros machine.config (también localizados en herramientas administrativas configuración de .net framework).

 

Estos ficheros son los encargados entre otras cosas de los permisos de ejecución no se actualizan automáticamente, tenemos que actualizarlos a mano.

Esto sólo es necesario en caso de que hayamos hecho algún cambio en las opciones de seguridad predeterminadas.

 

Otra posible solución es instalar la versión 2.0 de .net  sin actualizar los aplicativos existentes  ejecutando : el fichero de .net framework 2.0 dotnetfx.exe  con los parámetros /C:"install /noaspupgrade”

 

SI ya hemos actualizado (suele pasar) siempre podemos volver a re-configurar el .net ejecutando el progama  aspnet_regiis.exe

Situado en C:\windows\Microsoft.net\Version.

 

Tendremos una carpeta versión para cada versión de .net instalada en nuestra máquina por lo que habrá que ejecutar  aspnet_regiis.exe sobre la versión que queramos establecer, para todos los aplicativos o para úno sólo

Para actualizar todos los aplicativos, vamos a la carpeta de la versión que queramos actualizar y escribimos

aspnet_regiis -i

Para actualizar un sólo aplicativo tenemos que usar las opciones -s (actualizar ruta)  o -sn (actualizar ruta y todos sus directorios virtuales de forma recursiva)

la ruta tiene el formato: W3SVC/1/ROOT/NombreApp/

 W3SVC/1/ROOT apuntaría a localhost para Personal web server o al directorio raiz de IIS para la versión completa.

por lo que para reparar mi aplicativo AldeaMedia dejando los demás intactos sería.

aspnet_regiis -s W3SVC/1/ROOT/AldeaMedia

Que lo disfruteis.

Pablo Gumpert  Formador-Consultor Microsoft certificado en .net

pablogum@aldeamedia.com

www.aldeamedia.com

Pablo  Gumpert  Fernandez (aldeamedia)
Compatibilidad ASP.NET 1.1 y ASP.NET 2.0
Pablo Gumpert Fernandez (aldeamedia)

Pablo Gumpert es formador y consultor oficial de Microsoft para .NET y SQL server.Lleva desarrollando desde hace más de diez años y durante ese tiempo ha trabajado como programador de videojuegos ,analista informático, experto en seguridad, DBA ... Actualmente se dedica sobre todo a la formación. Su especialidad es la programación en .NET aunque también es experto en MSSQL Server y en el año 2002 fundó su propia empresa colaboradora de diversos centros partner Microsoft.
Fecha de alta:10/11/2005
Última actualizacion:10/11/2005
Visitas totales:4763
Valorar el contenido:
Últimas consultas realizadas en los foros
Últimas preguntas sin contestar en los foros de devjoker.com